Adverti horiz upsell

Skiin 2.1.3 for Maya (maya script)

Evolutive weights / effector manager for Maya. Export Import large amount of deformer data

License
Button download
544 Downloads

Compatibility

  • 2017, 2016, 2015, 2014, 2013, 2012, 2011

Operating Systems

  • Linux
  • Mac
  • Windows

History

Created:09/16/2016
Last Modified:02/27/2017
File Size: 68.4 KB

Keywords

weight, deformer, skiin

Q/A

Error in Maya 2017

Date:02/26/2017
Submitted by: bamoota bamoota
Hi Mehdi,
I'm running the version of Skiin from your site (can't get the one frome highend3d to run at all) in Maya 2017.
I get the error:
# Error: line 1: ImportError: file C:\Users\mike\Documents\maya\scripts\Skiin\Skiin.py line 68: No module named PySide.QtCore # 
Looks like you have to recompile for PyQt2. Can you give us a version that will run in Maya2017 please?
 
mike 
act3animation@gmail.com
 

Replies to this question:

  • bamoota

    bamoota said almost 5 years ago:

    I should add when running the version from Creative Crash I get this error
     

    import sys
    sys.path.append('C:\Users\mike\Documents\maya\scripts\Skiin')
    import Skiin
    reload(Skiin)
    Skiin.Skiin_UI()
    # Error: line 1: AttributeError: file <maya console> line 5: 'module' object has no attribute 'Skiin_UI' #

  • mlouala

    mlouala said almost 5 years ago:

    Hi bamoota,
    You need to import the folder which contains Skiin's folder, not Skiin's folder itself, like that ;
     
    import sys
    sys.path.append(r'C:\Users\mike\Documents\maya\scripts')
    import Skiin
    reload(Skiin)
    Skiin.Skiin_UI()

     

    Actually, the scripts folder of Maya should already be loaded by default, just have a try just by typing ;

    import Skiin
    Skiin.Skiin_UI()

     

     Peace,
    Mehdi

  • Replyindent
    bamoota

    bamoota said almost 5 years ago:

    Thanks Mehdi, that did the trick.
    Skiin is great!
  • mlouala

    mlouala said almost 5 years ago:

    About the 2017 error this as been solved since a long time, are you still experiencing error with it ? The error you're quoting (# Error: line 1: ImportError: file C:\Users\mike\Documents\maya\scripts\Skiin\Skiin.py line 68: No module named PySide.QtCore # ) seems old ?
     
    Have a great day,
    Mehdi

Post a reply: